Crea un Custom Activado de la 4.1 ó de la 4.2.1 con sn0wbreeze, si lo creas de la 4.1 usa sn0wbreeze v2.1 si lo creas de la 4.2.1 usa sn0wbreeze v2.2.1, aquí te los dejo, acuérdate bajar el firm oficial de la versión con la que vas a trabajar (iOS 4.1 ó iOS 4.2.1)

[Sólo los usuarios registrados pueden ver los enlaces. ]