Para esa versión necesitas los SHSH los tienes? Si no te va a tocar dejarlo ahí en la 4.1