Lamentablemente la unica forma que podes hacerlo es como te dije y arriesgarte, sino te vas a quedar en la 5.x que tengas...