Al tener ese basejand, para actualizar tenes que usar custom si o si, sino da error 1015 y queda en recovery...

Busca en mi guia los customs 4.2.1 (aunq en 3G anda mejor el 4.1) y una vez que este funcionando correctamente proba con el tuto de downgradear baseband, en una de esas tenes suerte y podes bajarla a 5.13 para evitar unos cuantos problemas...