yo tengo 4.2.1 y todo bien no se si actualizar